ccie blog

EoMPLS

Jim wants to to be in the same VLAN as Bob.  So when Jim checks his arp table, he should be able to pick up Bob’s mac address. To enable them to do that through our ISP’s layer 3 network we are going to use EoMPLS .  Alternative methods that can be used to acheive this are QinQ or VPLS.

Let’s start by configuring cpe1 & cpe2.

Cpe1#
 interface FastEthernet0/1
 description Link to pe1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 234
 switchport mode trunk
!
interface FastEthernet0/2
 Link to Jim
 switchport access vlan 234
 switchport mode access

Cpe2#
interface FastEthernet0/1
 description Link to pe2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 234
 switchport mode trunk
!
interface FastEthernet0/2
 description link to Bob
 switchport access vlan 234
 switchport mode access

 

The dedicated VLAN for our customer is 234.  So we just need to make sure we allow VLAN 234 over the trunk. Next, let’s configure pe1 & pe2.  I’m gonna make a loopback interface to use as our router-id for our Label Distribution Protocol (LDP). Next, I’m going to configure OSPF as our IGP for the ISP routers. OSPF also allows LDP to build labels for the different networks in the ISP.  I’m then going to finalize my configs using a xconnect to reach the other side.

pe1#
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip ospf network point-to-point
!
interface GigabitEthernet0/0
 ip address 10.0.0.2 255.255.255.252
 mpls label protocol ldp
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 10.0.0.0 0.0.0.3 area 0
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet0/1.234
 encapsulation dot1Q 234
 xconnect 4.4.4.4 234 encapsulation mpls

pe2#
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip ospf network point-to-point
!
interface GigabitEthernet0/0
 ip address 10.0.0.6 255.255.255.252
 mpls label protocol ldp
 mpls ip
!
router ospf 1
 router-id 4.4.4.4
 network 4.4.4.4 0.0.0.0 area 0
 network 10.0.0.4 0.0.0.3 area 0
!
mpls ldp router-id Loopback0 force
!
interface GigabitEthernet0/1.234
 encapsulation dot1Q 234
 xconnect 2.2.2.2 234 encapsulation mpls

 

The xconnect just needed an IP of its destination and a circuit identifier (in my config, I just used the VLAN number as the circuit-id). I made lo0 so that we can use it’s IP address as our router-id for our Label Distribution Protocol (LDP).  We need to advertise this router-id into OSPF so that our neighbors can become adjacent.  Sounds simple, but I didn’t do that! To debug problems with mpls LDP I used:

      • debug tag-switching tdp transport events
      • debug tag-switching adjancency

The first command will show you everything that goes wrong in terms of protocol (LDP/TDP).  When I originally played with this setup, this command found that I was using TDP on one router, and LDP on the other, which led to my neighbors failing to become adjancent.  The second command identified that my routers didn’t become adjancent due to the neighbor’s ldp router-id being unreachable (obviously this was all fixed when I provided the config above). So to sum up, the Jim is using VLAN 234, it hits the service providers dedicated sub-interface (at pe1), it’s then sent over the MPLS backbone using labels.  It hits pe2′s dedicated sub-interface which sends VLAN 234 traffic to the Cpe2 switch , and the customer is able to connect his sites together at layer 2. To complete the config, I have provided the output of the P1 router below.

p1#
tag-switching tdp router-id Loopback0 force
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet0/1
ip address 10.0.0.5 255.255.255.252
mpls label protocol ldp
tag-switching ip
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.0 0.0.0.255 area 0
network 10.0.0.0 0.0.0.3 area 0
network 10.0.0.4 0.0.0.3 area 0

 

Now when Jim checks his config, we should see bobs mac.

Notice he has an arp entry for 16.16.16.2, and no default-gateway.

The same goes for Bob:

How cool is that!

6 Comments

Bobby PizurFebruary 29th, 2012 at 9:21 pm

I like reading through and I think this website got some really useful stuff on it!

saintabreeyJuly 17th, 2014 at 9:29 am

hi there sir,
Why do you use tag switching instead of use ldp switching at p1? I use all mpls ldp and it worked too.

StephenGarbettJuly 24th, 2014 at 8:34 am

Hi, actually I had a problem with interoperability with the routers I was using (I had a really old version of code i was using). I might make another lab using just LDP. Nobody ever uses TDP in modern networks unless they have a old router that doesn’t support it.

/>NopeMarch 3rd, 2015 at 9:17 pm

/textarea>THIS WILL FUCK IT UP!

StephenGarbettJune 18th, 2015 at 11:58 am

No it wont bitch 😛

llldApril 10th, 2015 at 12:15 am

Nice post 😉
A good one is also below..

http://ipcisco.com/mpls-label-distribution-protocol-ldp-part-1/

Leave a comment

Your comment